This is very useful in a lab environment in which you could establish multiple BGP neighborship with single physical link between ACI & Switch.
We are going to create two neigbours in different vrf BGP & BGGP
Step 1: Check the connectivity between Nexus Switch and Leaf
n9k# show lldp nei int eth1/25
Device ID Local Intf Hold-time Capability Port ID
leaf5 Eth1/25 120 BR Eth1/15
Step 2: Let create Vlan93 on nexus switch connected to leaf.
interface Vlan93
no shutdown
vrf member BGP
ip address 222.222.221.2/24
Step 3: Create a loopback interface to advertise a network into BGP.
interface loopback101
vrf member BGP
ip address 66.66.66.66/32
Step 4: Create a Trunk Interface.
interface Ethernet1/25
switchport mode trunk
switchport trunk allowed vlan 93
Step 5: Configure BGP on nexus switch
Create vrf BGP on nexus switch
n9k(config)# vrf context BGP
n9k# show run | sec bgp
router bgp 369
vrf BGP
router-id 1.2.3.4
address-family ipv4 unicast
network 66.66.66.66/32
neighbor 222.222.221.1
remote-as 963
update-source Vlan93
ebgp-multihop 2
address-family ipv4 unicast
Step 6: Create L3 Out on ACI
Go to Vrf ISP
Here Ip address of BGP neighbour is 222.222.221.1/24
Now let's create one more vrf BGGP and interface vlan96
interface Vlan96
no shutdown
vrf member BGP
ip address 222.222.222.2/24
interface loopback1023
vrf member BGGP
ip address 33.33.33.33/32
interface Ethernet1/25
switchport mode trunk
switchport trunk allowed vlan 93,96
n9k# show run | section bgp
feature bgp
router bgp 369
vrf BGGP
address-family ipv4 unicast
network 33.33.33.33/32
neighbor 222.222.222.1
remote-as 963
update-source Vlan96
ebgp-multihop 2
address-family ipv4 unicast
vrf BGP
router-id 1.2.3.4
address-family ipv4 unicast
network 66.66.66.66/32
neighbor 222.222.221.1
remote-as 963
update-source Vlan93
ebgp-multihop 2
address-family ipv4 unicast
bgl-aci13-leaf5# show ip bgp summary vrf all
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
222.222.221.2 4 369 37 36 45 0 0 00:26:33 1
222.222.222.2 4 369 12 12 45 0 0 00:00:29 1
leaf5# show ip route bgp vrf ISP:VRF-ISP
IP Route Table for VRF "ISP:VRF-ISP"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>
1.1.1.1/32, ubest/mbest: 1/0
*via 10.0.120.67%overlay-1, [1/0], 00:41:46, bgp-963, internal, tag 963
10.0.0.0/24, ubest/mbest: 1/0
*via 10.0.120.67%overlay-1, [200/0], 00:41:46, bgp-963, internal, tag 963
33.33.33.33/32, ubest/mbest: 1/0
*via 222.222.222.2%ISP:VRF-ISP, [20/0], 00:11:39, bgp-963, external, tag 369
66.66.66.66/32, ubest/mbest: 1/0
*via 222.222.221.2%ISP:VRF-ISP, [20/0], 00:00:30, bgp-963, external, tag 369
102.102.102.1/32, ubest/mbest: 1/0
*via 10.0.120.67%overlay-1, [200/5], 00:41:46, bgp-963, internal, tag 963
Comments