top of page
Writer's pictureMukesh Chanderia

Lab2: Ping Two Endpoint (Host) connected to different EPG


Step 1: Take one more host say 6.6.6.2/24



Let’s assign 6.6.6.2/24 to interface eth1/21 of NX-Sw which is directly connected to eth1/11 of Leaf5.


Sw1# show run int eth1/21

interface Ethernet1/21

no switchport

vrf member POC2

ip address 6.6.6.2/24

no shutdown


Step 2: Create BD name “POC1-BD2”








Step 3: Create EPG “POC1-EPG2” and put this in “POC1-BD2”





Step 4: Add physical domain and create static port binding







Step 5: Now let’s do physical binding of Leaf 5 port eth1/11


Create interface Profile for port 11 say “11”


Step 6: Now attach this interface profile with Leaf 5





Step 7: Ping Host to it’s Gw



Sw1# show run int eth1/21

interface Ethernet1/21

no switchport

vrf member POC2

ip address 6.6.6.1/24

no shutdown



Sw1# ping 6.6.6.6 vrf POC2

PING 6.6.6.6 (6.6.6.6): 56 data bytes

36 bytes from 6.6.6.1: Destination Host Unreachable

Request 0 timed out

64 bytes from 6.6.6.6: icmp_seq=1 ttl=63 time=1.473 ms

64 bytes from 6.6.6.6: icmp_seq=2 ttl=63 time=1.014 ms

64 bytes from 6.6.6.6: icmp_seq=3 ttl=63 time=1.043 ms

64 bytes from 6.6.6.6: icmp_seq=4 ttl=63 time=1.128 ms


--- 6.6.6.6 ping statistics ---

5 packets transmitted, 4 packets received, 20.00% packet loss

round-trip min/avg/max = 1.014/1.164/1.473 ms


Step 8: Now to ping hosts between two EPG we need a contract.


Let’s Create Contract








Note: By Default, "Reverse Filter Ports" is selected.


Step 9: Attach provider contract to EPG1





And consumer contract in EPG2




Sw1# ping 3.3.3.1 vrf POC2

PING 3.3.3.1 (3.3.3.1): 56 data bytes

64 bytes from 3.3.3.1: icmp_seq=0 ttl=252 time=2.078 ms

64 bytes from 3.3.3.1: icmp_seq=1 ttl=252 time=1.721 ms

64 bytes from 3.3.3.1: icmp_seq=2 ttl=252 time=1.786 ms

64 bytes from 3.3.3.1: icmp_seq=3 ttl=252 time=1.93 ms

64 bytes from 3.3.3.1: icmp_seq=4 ttl=252 time=1.863 ms


--- 3.3.3.1 ping statistics ---

5 packets transmitted, 5 packets received, 0.00% packet loss

round-trip min/avg/max = 1.721/1.875/2.078 ms


Sw1# ping 6.6.6.1 vrf POC1

PING 6.6.6.1 (6.6.6.1): 56 data bytes

64 bytes from 6.6.6.1: icmp_seq=0 ttl=252 time=2.154 ms

64 bytes from 6.6.6.1: icmp_seq=1 ttl=252 time=2.26 ms

64 bytes from 6.6.6.1: icmp_seq=2 ttl=252 time=2.038 ms

64 bytes from 6.6.6.1: icmp_seq=3 ttl=252 time=1.946 ms

64 bytes from 6.6.6.1: icmp_seq=4 ttl=252 time=1.728 ms


--- 6.6.6.1 ping statistics ---

5 packets transmitted, 5 packets received, 0.00% packet loss

round-trip min/avg/max = 1.728/2.025/2.26 ms


So, we could see traffic is flowing bidirectional


It worked, why?


Reverse Filter Port is check






10 views0 comments

Comments


bottom of page