Fex device download NXOS image once connected to Parent Switch.
No Local Switching - It means that two devices connected to same FEX can’t communicate without going through Parent Switch.
Maximum 12 FEX devices can be connected to a Single Parent Switch.
FEX feature has to be enabled before using it using “feature fex”.
Configure switchport of Parent Switch to “fex-fabric” mode using “switchport mode fex-fabric” command.
There are two ways to configure Switchports connected to FEX. First is Static Pinning and Second is Port Channel.
Static Pinning
Here it is required to Map front panel ports. So, if you have two ports 13,14 being used for connecting FEX and if FEX has 48 ports in front panel- Then first half of the ports will be mapped to port 13 and next 24 with port 14. So, if port 13 goes down then first 24 ports of Front panel ports will not work. These will remain down by default.
To activate eth1/14
# fex pinning redistribute 100
So, to avoid outage we usually configure port channel rather than pinning port.
Let's see it's configuration
First enable fex feature
Config t # feature fex
Say Fex port is connected to 5K on int eth1/13
Int eth1/13
Switchport mode fex-fabric
No shutdown
(conf-int) # Fex 100
Pinning max-links 2 --> say two ports are connected to 5K so let other be eth1/14 (on 5K)
Exit
Now if eth1/13 goes down then eth1/14 won’t take over by default
Config t
Int e1/13 --> attach fex number to 2k switch
Fex associate 100
Now do the configuration on port 14 as well
Int eth1/14
Switchport mode fex-fabric
No shutdown
Pinning max-links 2
Fex associate 100
Port Channel Configuration
Here we will require to associate Fex number to port-channel
Int e1/13,Int e1/14
No shutdown
Channel-group 12 mode on (Fex don’t support lacp)
Int po12
Switchport mode fex-fabric
Pinning max-links 1
Fex associate 101
vPC Configuration
interface Po12
description UPLINK FEX-01
vpc 101
switchport mode fex-fabric
fex associate 101
no shut
interface Ethernet1/1
description UPLINK FEX-01
switchport mode fex-fabric
fex associate 101
channel-group 101
no shut
interface Ethernet1/9
description UPLINK FEX-01
switchport mode fex-fabric
fex associate 101
channel-group 101
no shut
Comments